Editing and Building Menus

From Galen Healthcare Solutions - Allscripts TouchWorks EHR Wiki
Jump to: navigation, search

Overview

Before you begin building menus, make sure you have reviewed information in the Wiki about Creating TouchWorks Users so that you can build menus that are tailored to the roles of your organization.

To complete the Menus task for the Build workbook you need to Review Workplace menus, update as needed, and Add PAT to the Workplace Menu

Menus consist of:

  • The WP Workplace
  • The VTB Vertical Tool Bar
  • The HTB Horizontal Tool Bar
  • Documents are pre-delivered from Allscripts.

Both the Vertical and Horizontal toolbars are configurable to meet the needs of the client.

SS01.jpg

Captions is the term Touchworks uses for names given to menu items – “Schedule” is the selected caption on the VTB in the above example.

(Touchworks uses 'Menu' as the Menu Type for Horizontal Toolbars?)

The way menus work

Select an item from the Vertical Tool Bar (in the above example, “Schedule”) This displays a Horizontal Toolbar of Tabs (Daily, Provider Schedule, Patient List, etc.) It also displays the default document for “Schedule” which in this example is the "Daily Schedule". Clicking on the tabs on the horizontal tool bar, a user can move between documents.

Best Practice

It is best practice to make menus role specific. (ie. The menu items for a nurse may differ from the menu items for a provider or a resident)

When creating menu components do not use the default menus that Allscripts provides. During upgrades and service packs, the default menus may get overwritten to their default settings and remove any changes you may have made.

It is best to create a standard process for naming menu items within TouchWorks. When creating a new menu item, the ID should be created using the following format:

<Client Menmonic>_<Role>_<Menu Type>_<Phase>

For Example: GHS_Provider_WP_P1 - This would be the Galen Healthcare Solutions Provider workplace for Phase 1

GHS_ClinicianChart_HTB_P1 - This would be the Chart HTB for a clinician for Phase 1

Using a naming convention such as this ensures that everyone on your team can understand what each menu item pertains to and also makes it easier to support in the future. If for instance you determine that after going live, it would be much easier for providers to have the batch signing page on their chart HTB, it is very easy to find the clinician chart definition and add that item without affecting any other users.


When Building menus, the best practice is to work from the bottom up, building the HTB tabs for documents first, then building the VTB.

Building Menus, Step by Step

Begin with creating all of your HTB's.

  1. Log in to TWAdmin and navigate to the Admin workspace.
    Menus 2.png
  2. Select Menus from the Vertical Toolbar
    Menus 3.png
  3. Select New from the Horizontal Toolbar
    Menus 4.png
  4. Select TOUCHWORKS for the Product and Application in v10. In v11, select 'Enterprise EHR' for Product and 'Touchworks' for Application.
    Menus 5.png
  5. Create an ID for the menu you are creating. This ID needs to be unique and follow the naming convention:
    <Client Menmonic>_<Role><Menu Type>_<Phase>
    For this example it would be:
    NWH_ClinicianChart_HTB_P1
  6. Create a caption. Captions do not need to be unique. Caption is the name that appears in the Vertical Toolbar. In this case the caption would be 'Chart'.
  7. Then select the type of menu you are creating.
    SS4a.jpg
  8. Click Save in the upper right hand corner.
    SS5.jpg
  9. Click ok
    SS6.jpg
  • Select Add (top right hand side of the dialog box)
    SS8.jpg
  • Under “Type” use the dropdown menu to select the appropriate child menu item.
    • If you are creating a horizontal tool bar your type will be “Document”
    • If you are creating a vertical tool bar your child type will be “HTB”
    • If you are creating a workplace, your child type will be “VTB”

In this example we will select Document

Ss9.jpg

  • Click on the ellipsis
    SS77.jpg
  • Type a keyword in the caption field and click on search to look for documents.
    SS10.jpg
  • Highlight the document you want and click on the select button in the upper right hand corner of the screen.
    SS11.jpg

We have now added the Clinical Desktop document and Tab to the Horizontal tool bar captioned “chart.”

To add another document, click add and repeat the process above. When finished, click on save.

SS12.jpg

Once saved, you can navigate to the “Edit” tab at the top of your screen. Here in the Banner you can see what menu you are working on (this is similar to how you see a patient name when you are working in Touchworks on the front end.)

  • Select a default document. This will be the document that the provider wants to see first when they make their selection from the vertical tool bar.
  • Continue to build all of the HTBs that you will need for this specific role (nurse, provider, front desk)
  • Once all of the HTBs are complete, then you can follow the same steps to build the Vertical Tool Bar.
    SS13.jpg
  • Select Touchworks for the Product and application
  • Create a unique identifier for the ID using the naming convention
  • Select Vertical toolbar for Type
  • Click on the save button in the upper right hand corner
    Ss14.jpg
  • Click OK
    Ss15.jpg
  • Click Add
    Ss16.jpg
  • Select HTB for Type in the Menu items Dialog box
  • Click on the ellipses to select your menu
    Ss175.jpg
  • Search for the HTBs that you built using your unique identifiers
  • Highlight the HTB that you created and click on Select in the upper right hand corner of the dialog box.
    Ss18.jpg
  • Select all of the HTB items that you want to appear in the VTB that you are creating. Then click on the save button in the upper right hand corner of the screen.

The Vertical and Horizontal Toolbars have been created. To become functional these menus must assigned to users using TWAdmin. From the Vertical Toolbar in the TWAdmin workspaces, select TWUser Admin, select a user, scroll down to workplaces, and set the workplace to the user.

Editing Menus

How to Edit existing menus

For this example we will look at the hypothetical situation that an organization does not want Providers to have the cross patient 'Worklist' (document) as an option when they select 'Chart' (caption) from the Horizontal Tool Bar.

  • Login as TW Admin
  • Navigate to the Admin Workspace
  • Select Menus
  • Select Edit
    MenuEdit1.jpg
  • Select 'Touchworks' for Product and Application
    Menuedit2.jpg
  • Select from the dropdown menu the type of menu that you want to change (Vertical Toolbar)
  • Click on search
    Menuedit3.jpg
  • Make sure you choose the correct menu from the returned list. For this example we are looking for a VTB menu with the name 'Provider'. There are two menus in the list named 'Provider' look at the blue underlined ID to determine which one to modify. In this example we already know '3D ProviderVTB' is an older version of 'Clinician' and that we wish to change the newer version only.
    Select VTB.jpg
  • Select the menu that you would like to edit by clicking on the blue underlined text in the menu name
  • The Edit Menu screen will appear:
    Menuedit5.jpg
  • Select the “Summary” tab at the top of the page
    Menuedit6.jpg
  • Select the menu that you want to edit. In this example we already know that the worklist document is in the horizontal tool bar named 'Chart'. Caption = name, So we will select the menu with caption 'Chart'.
    Note: The Menu Type for Horizontal Toolbars is "Menu."
    Menuedit7.jpg
  • A Dialog Box titled “Summary” will appear.
  • Click on Edit
    Menuedit8.jpg
  • A “New/Edit Menu” Dialog Box will appear
  • Click on edit menu items
    Menuedit9.jpg
  • A Menu Items dialog box will appear.
    Menuedit10.jpg
  • To remove an item, simply click on the “Remove” button next to its name
    Menuedit11.jpg
  • To Add an item, Click on the “Insert” button next to an existing item and a new blank item will appear when you have completed your changes.
    Menuedit12.jpg
  • Make sure you click on the SAVE button to make sure your changes will take effect.
    Menuedit13.jpg