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Precision.BI Version 4.5.0803
 Release Notes Enhancement Details
Introduction

Precision.BI (PBI) version 4.5.0803 is a minor release of the software. The minor release includes several enhancements related to the tree view functionality.  The following document provides detailed information on the enhancements contained in version 4.5.0803.
Features:

Release 4.5.0803 contains the following new software features that relate to the tree view:
· Multiple tree views can now be configured at an individual client site.  A site default tree view will exist. An individual user can be set to view the site default tree view or can set another tree view as their default.
· There is now an unlimited number of levels that can be set up in the tree view hierarchy.
· Users should see an improvement in speed when loading the tree view.
· If a network interruption occurred while saving tree view changes – this could lead to a corruption of the tree view.  Improvements have been made to the save process to significantly reduce the chance of corruption.  
· Security can be configured to allow or disallow a user to create/modify a tree view.  Security can also be configured to allow or disallow a user from switching to a different tree view within an ad hoc module.

Enabling the Functionality:

Security must be properly configured in order to utilize the new features.  Some, all, or none of the new functionality may be enabled for each user depending on their role.  Each tree view is considered an object like a worksheet, analysis, chart, report, etc.  Each tree view object has an owner and security can be assigned in Group Object Security
1. Group Forms - There are security considerations at the Group Form level.  Two new group forms exist: New Metalayer Tree and User Metalayer Functions.
a) New Metalayer Tree – A user must have access to the existing group form Metalayer Engine to be able to access the tree view screen in metalayer module.  Having the New Metalayer Tree form will allow the user to create and save new tree views.  If the user has only Metalayer Engine but no access to New Metalayer Tree – they will only be able to modify their default tree view IF they are the owner or they have View/Modify/Save rights.
b) User Metalayer Functions – The user must have access to User Metalayer Functions in Group Form security in order to enable the tree view menu in the ad-hoc modules.  This menu allows the user to open other tree views he/she has access to.  In addition, a user default tree view can be assigned from this menu.
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2. Group Objects – Metalayer Trees are now objects that are listed in Object Management.  The owner of the tree view can modify it even if the object is not listed in Group Objects security.  When adding a tree view to Group Objects security – the security group can have View rights, View/Modify rights, or View/Modify/Save rights.  Please note that all users have at least View rights to the Site Default tree view – even if they have not been given access in Group Objects security.  This will allow the user to still be able to work within the modules even if no tree view has been explicitly assigned in Group Objects.
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3. User Management – The User Management screen is where a user can be granted access to setting the site default.  The User Management screen is also where User Default tree view setting can be viewed or modified.  
a) Is Admin Flag - A user must have a value of ‘Yes’ in the Is Admin field within User Security in order to set a new site default tree view.  
b) Default Metalayer Tree – A user default metalayer tree can be viewed or modified from the User Management Screen.  Please note that upon upgrade to 4.5.0803 all users will have the site default tree as their user default.  The site default is equivalent to the existing tree view before the upgrade.  If the site default is changed – all users will not automatically have their user default updated.
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Please Note:  If a tree view object is set to either the site default or a user’s default – it cannot be deleted from the Object Management screen.  A new site default or user default will have to be assigned before the Metalayer Tree object can be deleted.  
Creating/Modifying a Metalayer Tree:

Accessing the tree view configuration screen is done in the same manner as previous releases.  A user must have access to the Metalayer Engine form.  Click the tree view icon at the top to open the tree view screen.  When entering this screen the user’s default tree view will be displayed.  If the user does not have a user default tree assigned, the site default will be displayed.
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1. Opening a Tree View - If you do not wish to modify your user default tree view – you can open another tree view which you have access to. ( In order to make modifications you will need to be either the ‘Owner’ or have the appropriate rights in Group Object security. ) 

Either click the File menu and then Open or click on the Open icon in the tool bar.  A dialog box will appear containing those tree views that the user has access to.  Double click on the appropriate tree view or click once and then ‘Ok.  (The name of the tree view that is currently open is displayed at the bottom left side of the screen.)
The tree view will load.  Once loaded – the user can either create new root levels, create new child levels within a root, or add fields to existing levels
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2. Adding a Root or Child Level – Click on the ‘Add’ button to open the Add menu.  Click Root Level to create a new root level folder.  The new root level folder will appear at the bottom of the tree view.  When it appears simply begin typing to give it a name.  (The default name is ‘New Category’)  You can click and drag to move the root level folder to a different location within the tree view.
When adding a Child Level you must first click on the appropriate root level first and expand it.  Once the root level is open, then click on the Add menu to select Child Level.  The new child level will appear at the bottom of the root level section and can be renamed. (The default name is ‘New Category’.)
The ‘Add’ menu is also available by right clicking on a level in the tree view.

Please Note:  The user cannot create duplicate child level folders within a root. Duplicate root level folders cannot exist either.  If you create a new level and do not immediately rename – you may see a duplicate ‘New Category’ description until you rename.
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3. Removing a Field or Level – Right click on the level or field you would like to remove and click on ‘Delete’.  Multiple fields can be selected for deletion at once by pressing the Control key and then clicking to highlight the fields.  Once the fields are selected, right click on the last field and click ‘Delete’.
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4. Renaming Levels - Right click on a level folder and select ‘Rename’.  Type the new name in the rectangle.  In addition, a description can be added for the level folder by double clicking on the root or child level.
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5. Adding Fields  - Fields can be added to the tree view in several different ways.  Click on the tree view to expand it and select the root or child level where you want the new field added.  Click the field name on the right and drag it over to the proper location.  The Control or Shift keys can be used to select multiple fields at a time.  A line will appear to guide you to the proper location.
Fields can also be added by clicking on the appropriate location in the tree view.  Next, select one or more fields from the list of available fields.  Then click on the ‘Add’ menu and ‘Selected Fields’.
Please Note: A root level must have at least one child before fields can be added.  A maximum of 255 fields can be added to any level.
Please Note:  Only fields not currently in the tree view will be displayed on the right side of the screen. 
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6. Moving Fields – Click on a field in the tree view and drag it to the correct location.  Multiple fields cannot be selected and moved at once.  Single fields can be moved between root or child levels or within the same level.
7. Saving Changes - The user can either perform a Save or Save-As depending upon the access that has been assigned in security.  To either Save or Save-As click on the File Menu or click on the Save icons in the tool bar.  If performing as Save-As the user will be prompted to enter a name for the tree view and a category.
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Creating a New Metalayer Tree:

Click the New option from the File Menu or click on the New icon in the tool bar.  Begin by adding root levels.  Add additional levels and fields as indicated above.  Do not save a tree view that has no fields.
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Setting the Site Default:

In order to change the site default the user must have a ‘Yes’ in the ‘Is Admin?’ flag within User Management.  To set a site default – open the tree view by clicking the Open icon on the tool bar.  Select the appropriate tree view from the dialog box.  Click the Site Default option in the tool bar to complete the process.
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Please Note:  that the tree view that is currently set as the site default will indicate ‘Site Default’ in parentheses behind the name of the tree view in the bottom left corner of the screen. 
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Keyword Search:

To quickly locate a field within the tree view – click the Keyword button.  Type in a part of the text and fields that match will be displayed.  Double click on the correct field and your cursor will move to that location in the tree view.
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Collapse:

Click the Collapse button to quickly collapse the tree view levels.
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Accessing Tree Views in the Ad-hoc Modules:

If the user has access in Group Forms security to the User Metalayer Functions, the Tree View options icon will be displayed at the top right side of the tree view.  When logging into the system the user’s default tree view will be displayed.  
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The user can click ‘Open Metalayer Tree’ to open a dialog box containing all available tree views that the user can select.  The Recently Used tab will display the last 10 tree views that have been accessed by the user.
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Setting a User Default Tree View:

Click the Default Metalayer Tree option to change the current tree view to your user default tree.  The next time that user logs in he/she user will see the new default tree displayed.  The field called Default Metalayer Tree in User Management will be updated when the user changes his/her default.  Someone with access to User Management can also change the user default tree there.
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Known Tree View Related Issues in Release 4.5.0803:

· Distinct value icon appears in the tree view when the field is initially added.  If the tree view is opened again the icon is correct.  In addition, the fields display with the correct icon in the ad-hoc modules.(Case 6995)
· A field cannot be renamed from the tree view screen in the Metalayer Engine if newly added.  A ‘type mismatch’ error will occur.  Fields that were previously saved can be renamed by double clicking the field. (Case 7153)
· An error will occur if a completely blank tree view is saved.

· When selecting Keyword Search the fields listed will be associated with the user default tree.  Therefore, if you open a new tree from the tree view workspace screen the Keyword Search will not function properly. The ad-hoc module keyword search is not affected. (Case 7156)

· Multiple fields can be highlighted in the tree view workspace but cannot be dragged to a new location in the tree view.  Multiple fields can be selected and added.  However, the issue is with moving existing fields within the tree view (Case 7155).

· Multiple fields can be selected from the tree view and deleted but the user must right click on the last field selected. (Case 7154).
· When adding fields to the tree view using the Add menu the tree isn’t automatically refreshed.  Collapsing and reopening the tree will allow the fields to be displayed.  This issue does not affect adding the fields by clicking and dragging. (Case 7152)

· When a field is deleted from the tree view it is re-add to the list of available fields on the right.  However, the field description does not properly appear.  If the tree view is reopened the field description is fine. (Case 7150)[image: image19.png]L Dashboard Management
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‘Yes’ in the 


‘Is Admin?’ Flag allows changing the site default





‘Default Metalayer Tree’ displays the user’s default tree view.





Click here to open an existing tree view





Use the ‘Add’ menu to add root levels, child levels, or fields





To remove a field or level – right click and select Delete





To rename a level - Right click on the level and select Rename





Click on the Save or Save-As icons to save your changes





Click the Site Default button to make the open tree view the new site default





The current site default tree view will have a note at the bottom of the screen





Keyword Search





Collapse Tree





Click the New icon to create a new tree view.





Click on the User Metalayer icon to open the menu





Click Default Metalayer Tree to set the current tree as the user default
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